Knowledgebase article 2

Tomcat is using an incorrect version of Java (for Java errors)


This article contains information to modify the version of Java that Tomcat uses.  This becomes necessary you have (or want) multiple versions of Java installed on the same machine, or you're getting a Java related error message from Tomcat.

If you are instructed (below) to download Java JDK, Please download it here:
http://www.oracle.com/technetwork/java/javase/downloads/index.html


For additional instructions (that usually contain images), see the attached document.

Note: Our installer (version 9.1 and higher) comes bundled with the correct version of Java.  This resolution page is divided into 4 sections for different installation scenarios.

Windows (for customers who have used our installer, version 9.1 and higher):

1.  Identify which version of Java your Tomcat server is using.
 1a.  Run (as administrator) the "Configure Tomcat" application.  (tomcat5w.exe located in the tomcat directory root\bin\).
 1b.  Click on the Java tab.
 2c.  The "Java Virtual Machine" path should point to jvm.dll located inside the eHD installation folder.  The default path for this is C:\Program Files\GroupLink\everything HelpDesk\jre\bin\server.

2.  If jvm.dll is not located inside the eHD\jre\bin\server\ folder, please change it by clicking the ellipse command button "...".

3.  Restart the tomcat service for the changes to take effect.

 

 Windows (for customers who have not used our installer, version 9.0.5 and lower):

1.  Identify which version of Java your Tomcat server is using.
 1a.  Run (as administrator) the "Configure Tomcat" application.  (tomcat5w.exe located in the tomcat directory root\bin\).
 1b.  Click on the Java tab.
 1c.  The "Java Virtual Machine" path should point to the installation of Java JDK 1.5 or higher.  This can look something like C:\Program Files\Java\jdk1.6.0_24\jre\bin\serverr\jvm.dll.

2.  Make the necessary changes to the "Java Virtual Machine" settings.  If you don't have Java installed, please install it (from the above link) and link to that instillation directory.

2.  Restart the tomcat service for the changes to take effect.

 

Linux (for customers who have used our installer, version 9.1 and higher):

1. Please call GroupLink support.

 

 

 

Linux (for customers who have not used our installer, version 9.0.5 and lower):

1.  Please call GroupLink support.

 

 

 


Email

To

  • eHD Standard Support
  • Nov 25, 2014
  • Public
  • 5811